Les erreurs suivantes ont été rencontré avec un serveur Xen Server 5.6 attaché via ISCI à un Openfiler 2.3.

Il se peut que vous ne puissiez pas reconnecter votre stockage partagé ISCI  sur un serveur Xen lorsque l’Openfiler 2.3 est redémarré pour la première fois et que le stockage a déjà été attaché.

Openfiler 2.3 présente un bug connu qui n’a pas été solutionné par une mise à jour.

Pour contourner le problème, connectez vous à la console de l’openfiler et loguez vous en tant que root; puis suivez la procédure suivante.

iSCSI Target ne semble pas démarrer correctement à cause d’un service appelé AOE(ATA over Ethernet) que vous devez désactiver à l’aide de la commande suivante:

chkconfig –level 345 aoe off

Rendez vous ensuite dans le dossier /etc/lvm du serveur et éditez le fichier lvm.conf

Rendez vous à la ligne 53 et changez les paramètres du filter pour qu’ils soient identiques à ceux ci dessous:

filter = [ "r|/dev/dm-*|", "r|/dev/VG_XenStorage*|", "r|/dev/sr/iscsi|", "a/.*/" ]

 

Sauvegardez le fichier.

Rendez vous ensuite dans le dossier /etc et éditez le fichier rc.sysinit et commentez les lignes 333 à 337 comme ci dessous.

#       if [ -x /sbin/lvm.static ]; then
#               if /sbin/lvm.static vgscan –mknodes –ignorelockingfailure > /dev/null 2>&1 ; then
#                    action $ »Setting up Logical Volume Management: » /sbin/lvm.static vgchange -a y -ignorelockingfailure
#               fi
#       fi

Sauvegardez le fichier et redémarrez le serveur Openfiler.

Après le redémarrage, tentez de reconnecter le stockage partagé depuis le Xen Server.